import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>\\S+[^\\S\\n]+){3,}?(\\S+?)\\K\\1(?!\\S)";
final String string = "00101 blah 0000202 thisisasentencethisisasentence 99929\n"
+ "00102 blah 0000202 thisisasentenc1thisisasentenc1 999292";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}