const regex = /^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>\\S+[^\\S\\n]+){3,}?(\\S+?)\\K\\1(?!\\S)', 'gm')
const str = `00101 blah 0000202 thisisasentencethisisasentence 99929
00102 blah 0000202 thisisasentenc1thisisasentenc1 999292`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);