package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(jack)?ass(es)?\b`)
var str = `Class
bass
glass
ass
asses
jackass
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}