const regex = /[A-z]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-z]', '')
const str = `abc_def^gh[ij]k\\lm-nop`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}