# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<property[^>]*name=\"(username|password)\".*?</property>"
test_str = "<property name=\"password\">QWERTY</property><property name=\"username\">Hello</property><property name=\"passive\">1</property><property name=\"password\">Test Password</property><property name=\"scheme\">smb</property><property name=\"timeout\">10000</property><property name=\"username\">RANDOM USER</property><property name=\"username\">Sid</property>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.