re = /<property[^>]*name="(username|password)".*?<\/property>/
str = '<property name="password">QWERTY</property><property name="username">Hello</property><property name="passive">1</property><property name="password">Test Password</property><property name="scheme">smb</property><property name="timeout">10000</property><property name="username">RANDOM USER</property><property name="username">Sid</property>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result