import Foundation
let pattern = #"\w+:\s*(.*?)(?=$|]|\s*\w+:(?:\w|\s))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
caller message: Class::method1()
caller message1: Class::method2() message2: Class1::method1(Class2::method2())
caller message: Class1::method1(Class2::method2())
caller message1: Class1::method1(Class2::method2()) message2: Class3::method3(Class4::message4())
Class1::method1(Class2::method2()) message2: Class3::method3(Class4::method4())
[Analytics reportEvent: GENERAL_EVENT usingID: getCurrentID() withParameter: Number::numberWithFloat(Number::defaultNumber() + 1)]
[Sequence actions: DelayTime::create(1.0), CallFunc::create(this, selector(explodeCells)), NULL]
[layer runAction: Sequence::actions(actionScale, NULL)]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)