re = /^([\s\t;]*)console./m
str = ' console.
;console.
//console.
console.log(\'Q ALL: SUCCESS\');'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end