use strict;
my $str = 'EC1A 1BB
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
EC1A1BB
A9A9AA
A99AA
A999AA
AA99AA
AA999AA';
my $regex = qr/([a-zA-Z][a-zA-Z0-9]{1,3}) ?(\d[a-zA-Z]{2})/imp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";