using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"widget\.method[\s]*\([\s]*[\'\""]([\w]*)[\'\""]";
string input = @"widget.method(""submit1"", function() {
});
widget.method('submit2', function() {
});
assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}