import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "widget\\.method[\\s]*\\([\\s]*[\\'\\\"]([\\w]*)[\\'\\\"]";
final String string = "widget.method(\"submit1\", function() {\n\n"
+ "});\n"
+ "widget.method('submit2', function() {\n\n"
+ "});\n"
+ "assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}