// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"widget\.method[\s]*\([\s]*[\'\"]([\w]*)[\'\"]"#).unwrap();
let string = "widget.method(\"submit1\", function() {
});
widget.method('submit2', function() {
});
assdfasdfadfasdcsv@p[qw:;lmdc kasdmcslkndxkv hbq1097736ty98ue9dewsuydfg8eaf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}