$re = '~<body\K~';
$str = '<body>
<div>(content)</div>
</body>';
$subst = " class=\"new_class_attr\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;