re = /^(?!-|.*(\.[.-]|-\.|-$))(?:[A-Z0-9-]{0,62}\.){1,8}[A-Z0-9]{3}$/mi
str = 'www.-site.com
www.site-.com
www.site.com
www.site..com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end