$re = '/\b(?!AND|OR)(?:\w+)/m';
$str = 'salesforce AND (microsoft OR 451)';
$subst = ".$0.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;