# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(d\\/)([A-z0-9]+)(\?)//gm;t' <<< "//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0"