#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(d\/)([A-z0-9]+)(\?)"
Local $sString = "//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)