using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(d\/)([A-z0-9]+)(\?)";
string substitution = @"";
string input = @"//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}