package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(d\/)([A-z0-9]+)(\?)`)
var str = `//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}