using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+\.\d+\.(?:\d+\.)*(?=.*\n\d+\.\d+\.(?:\d+\.)*)|\d+\.\d+\.(?:\d+\.)*(?!.*\n))";
string input = @"1.2.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}