#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)" & @CRLF & _
" (?<string>'[^']+')" & @CRLF & _
" (?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )" & @CRLF & _
" (?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )" & @CRLF & _
" (?<value> (?&string) | (?&array) )" & @CRLF & _
")" & @CRLF & _
"(?&value)"
Local $sString = "@include ('file_to_load','param1,something',['elem'=>'also, a comma','other'=>['nested' => 'array']])"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")