package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE)
(?<string>'[^']+')
(?<array> \[ (?: (?&arrayitem) (?> , \s* (?&arrayitem) )* )? \] )
(?<arrayitem> \s* (?&string) \s* => \s* (?&value) \s* )
(?<value> (?&string) | (?&array) )
)
(?&value)`)
var str = `@include ('file_to_load','param1,something',['elem'=>'also, a comma','other'=>['nested' => 'array']])`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}