# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"shawn_123\".*?\"id\":\s\"(\d+)\""
test_str = ("{\n"
"\"meta\": {\n"
"\"code\": 200\n"
"},\n"
"\"data\": [\n"
" {\n"
" \"username\": \"shawn_123\",\n"
" \"profile_picture\": \"https://scontent.cdninstagram.com/t51.2885- 19/s150x150/11417456_1610194859266611_592197892_a.jpg\",\n"
" \"id\": \"641567093\",\n"
" \"full_name\": \"shawn ritz\"\n"
"},\n"
" {\n"
" \"username\": \"shawn_12345\",\n"
" \"profile_picture\": \"https://scontent.cdninstagram.com/t51.2885-19/s150x150/11324946_808347519273018_2073555780_a.jpg\",\n"
" \"id\": \"2074312361\",\n"
" \"full_name\": \"shawney\"\n"
"}")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.