// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)"shawn_123".*?"id":\s"(\d+)""#).unwrap();
let string = "{
\"meta\": {
\"code\": 200
},
\"data\": [
{
\"username\": \"shawn_123\",
\"profile_picture\": \"https://scontent.cdninstagram.com/t51.2885- 19/s150x150/11417456_1610194859266611_592197892_a.jpg\",
\"id\": \"641567093\",
\"full_name\": \"shawn ritz\"
},
{
\"username\": \"shawn_12345\",
\"profile_picture\": \"https://scontent.cdninstagram.com/t51.2885-19/s150x150/11324946_808347519273018_2073555780_a.jpg\",
\"id\": \"2074312361\",
\"full_name\": \"shawney\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}