import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<type>[A-Z])(?<subtype>[<A-Z])(?<country>\\w{3})(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<complement><){0,}\\n(?<pnum>[\\d\\w]{9})(?<pnumcheck>\\d{1})(?<nat>\\w{3})(?<yob>\\d{2})(?<mob>\\d{2})(?<dob>\\d{2})(?<dobcheck>\\d{1})(?<sex>M|F|<{1})(?<yoe>\\d{2})(?<moe>\\d{2})(?<doe>\\d{2})(?<expcheck>\\d{1})(?<pid>[\\d\\w<]{14})(?<pidcheck>\\d{1})(?<generalcheck>\\d{1})";
final String string = "P<USADOE<<JOHN<WILLIAM<<<<<<<<<<<<<<<<<<<<<<\n"
+ "5039927858USA5509298M2304090255136054<115916";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}