// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<type>[A-Z])(?<subtype>[<A-Z])(?<country>\w{3})(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<complement><){0,}\n(?<pnum>[\d\w]{9})(?<pnumcheck>\d{1})(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2})(?<dobcheck>\d{1})(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2})(?<expcheck>\d{1})(?<pid>[\d\w<]{14})(?<pidcheck>\d{1})(?<generalcheck>\d{1})").unwrap();
let string = "P<USADOE<<JOHN<WILLIAM<<<<<<<<<<<<<<<<<<<<<<
5039927858USA5509298M2304090255136054<115916";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}