$re = '/^(?!%%)%(?:(?!%{2}|c%)[%DCS-])+$/m';
$str = '%DCS
%D%S
%D--S
%D%%S
%%DCS
%CCS
DSC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);