$re = '/(<table.*>)(<td.*)/';
$str = '<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...';
$subst = "$1<tr>$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;