# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<table.*>)(<td.*)"
test_str = ("<table border=\"0\" bgcolor=\"#FFFFFF\"><td bgcolor=...\n"
"<table width=\"780\"><td align=...")
subst = "$1<tr>$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.