import Foundation
let pattern = #"(<table.*>)(<td.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<tr>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)