#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)50F:(?:(?!:[0-9]{2,3}[A-Z]?:).)*?3\/([A-Z]{2})"
Local $sString = "some noise :50F: some noise 3/GB some noise :50A: " & @CRLF & _
"some noise :50F: some noise some noise :50A: 3/GB " & @CRLF & _
"some noise :50F: some : noise 3/GB some noise :50A: "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")