package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z ]+|\d+\.)+$`)
var str = `Foo foo fooooo 3`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}