$re = '/[\d]{4}(-|\/)[\d]{2}(-|\/)[\d]{2}/mi';
$str = '2000-02-02
1987-02-02
1000-sd-65
2100-12-87
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);