import Foundation
let pattern = #"(The reason for this is\s*:\s*)([\s\S]*?)(\s*Kind regards)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
The reason for this is: 111111111
2222
Kind regards.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}