re = /(The reason for this is\s*:\s*)(\S*(?:\s(?!\s*Kind regards)\S+)*)(\s*Kind regards)/
str = 'The reason for this is: 111111111
2222
3333
ddddddddd
Kind regards.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end