package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/h2>((?:\s|.)*)<h2`)
var str = `<h2>my title here</h2>
Lorem ipsum dolor sit amet
<h2>my title here</h2>
consectetur adipisicing elit quod tempora`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}