using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(CP-([0-9A-Z]{1,6})-SEP([0-9A-F]{12}))$";
string input = @"CP-8961-SEP1CAA07E2C8DE";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}