package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(CP-([0-9A-Z]{1,6})-SEP([0-9A-F]{12}))$`)
var str = `CP-8961-SEP1CAA07E2C8DE`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}