import re
regex = re.compile(r"^(CP-([0-9A-Z]{1,6})-SEP([0-9A-F]{12}))$")
test_str = "CP-8961-SEP1CAA07E2C8DE"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")