using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(path)(?:$|\?(?:(?=.*\b(foo=)(\d+)\b.*$)|(?!foo=).*?))";
string input = @"path?abc=123&foo=-999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}