# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?: |\G)\d\B\K/*/g;t' <<< "123 a123 1234567 b123 123"