using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"android(?!.*mobile)";
string input = @"android should be matched
android should not match on a mobile";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}