using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ^(?P<timestamp>\d{4}/\d{2}/\d{2}\ \d{2}:\d{2}:\d{2})
\ \[(?P<severity>emerg|alert|crit|error|warn|notice|info)\]
\ (?P<process_id>\d+)
\#(?P<thread_id>\d+):
\ \*(?P<connection_id>\d+)
\ (?P<error>.+?)
(?:\ while\ (?P<context>.+?))?
,\ client:\ (?P<client_ip>\d+\.\d+\.\d+\.\d+)
,\ server:\ (?P<server>.+?)
(?:,\ request:\ \""(?P<request_method>[A-Z]+?)
\ (?P<request_path>\/.+?)
\ (?P<request_protocol>.+?)\"")?
(?:,\ upstream:\ \""(?P<upstream>.+?)\"")?
(?:,\ host:\ \""(?P<host>.+?)\"")?
(?:,\ referrer:\ \""(?P<referrer>.+?)\"")?
$";
string input = @"2019/07/11 07:19:30 [error] 934#934: *18897816 open() ""/local/nginx/static/ads.txt"" failed (2: No such file or directory), client: 85.195.82.90, server: app.digitale-sammlungen.de, request: ""GET /ads.txt HTTP/1.1"", host: ""app.digitale-sammlungen.de""";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}