#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|(?<=[\s:]))(:[^\s:]+:)(?=[\s:]|$)"
Local $sString = ":match1::match2: :match3:" & @CRLF & _
":match4:" & @CRLF & _
"000:matchNot:" & @CRLF & _
":matchNot:000" & @CRLF & _
":match Not:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")