import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=[\\s:]))(:[^\\s:]+:)(?=[\\s:]|$)";
final String string = ":match1::match2: :match3:\n"
+ ":match4:\n"
+ "000:matchNot:\n"
+ ":matchNot:000\n"
+ ":match Not:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}