#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<textarea[\s\S]+?<\/textarea>)"
Local $sString = "<p>" & @CRLF & _
" <textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">" & @CRLF & _
" <p>5051950</p>" & @CRLF & _
" </textarea>" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">" & @CRLF & _
"" & @CRLF & _
"a é í <abc>" & @CRLF & _
"" & @CRLF & _
"</textarea></p>" & @CRLF & _
"" & @CRLF & _
"<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")