use strict;
my $str = '1d 2h 3m 4s
1h 2m 3s
1m 2s
1s
1d2h3m4s
1h2m3s
1m2s
1s';
my $regex = qr/^(?:(?:(?:(\d+)d\s*)?(\d+)h\s*)?(\d+)m\s*)?(\d+)s$/mp;
my $subst = '$1 days $2 hours $3 minutes $4 days';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";