// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:(?:(\d+)d\s*)?(\d+)h\s*)?(\d+)m\s*)?(\d+)s$").unwrap();
let string = "1d 2h 3m 4s
1h 2m 3s
1m 2s
1s
1d2h3m4s
1h2m3s
1m2s
1s";
let substitution = "$1 days $2 hours $3 minutes $4 days";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}