import Foundation
let pattern = #"(X+)\W(X+)\W(X+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1)(\2)(\3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)