import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\";
final String string = "if ( antrag . frage ( 'vNamen' ) . istBeantwortet ( ) ) {\n"
+ " antrag.istHauptantrag() ;\n"
+ "} else if (antrag . istAntragGleich ( 'a0001' ) || antrag . istWiederholungsantrag ( ) ) {\n"
+ " antrag.frage('vNamen').feld('name').laenge() > 0;\n"
+ "} else {\n"
+ " true;\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}